Original post

I have implemented a binary heap data structure, my code is inside binary_heap. in a package called binaryheap :blush:

This binaryheap package defines a struct, which has my binary heap implementation. How should I name this struct:

  • Client
  • Binary
  • Heap
  • Slice <- shows that I have implemented it using an underlying slice
  • Tree <- shows that I have implemented it using an underlying tree

Any suggestions ? What is the idiomatic way ?