Original post

Hi all,
For my tree data structure I want to create a method that returns true if the tree has no elements.

I already have a Clear() method to forcefully delete everything inside the tree. Which name should I use Empty or IsEmpty, what is more idiomatic to ?

Somehow Empty seems like a bad name, due to possible confusion, anyone else think the same ?